Tuesday, December 09, 2008


xVM on opensolaris 2008.11




My primary target was testing xVM performance at opensolaris 2008.11(based on 101b Nevada build). Solaris Nevada works smoothly with images located on UFS and zvols.Opensolaris 2008.11 requires only zvols as image devices for Xen Guests to be installed in reasonable time.I believe it's a known issue caused by ZFS. From my standpoint the most impressive UI feature is Package Manager. It's really helpful.


Install all members of Virtualization group via Package manager.






# cd /boot/grub/
# ln -s /rpool/boot/grub/menu.lst menu.lst

Add new entry to /boot/grub/menu.lst

title OpenSolaris 2008.11 snv_101b_rc2 X86 xVM
bootfs rpool/ROOT/opensolaris
kernel$ /boot/$ISADIR/xen.gz
module$ /platform/i86xpv/kernel/$ISADIR/unix /platform/i86xpv/kernel/$ISADIR/unix -B $ZFS-BOOTFS

Reboot into xen kernel and activate services as advised in [1]:-

# svcadm enable store
# svcadm enable xend
# svcadm enable console
# svcadm enable domains
# svcadm enable virtd

Make sure services are running:-

# svcs -a | grep xvm
online 13:45:52 svc:/system/xvm/vnc-config:default
online 13:45:53 svc:/system/xvm/store:default
online 13:46:03 svc:/system/xvm/xend:default
online 13:46:03 svc:/system/xvm/console:default
online 13:46:03 svc:/system/xvm/virtd:default
online 13:46:04 svc:/system/xvm/domains:default

One more test

xm info

To create zpool on Intel based PC run

root@opensolaris:~# format
Searching for disks...
The device does not support mode page 3 or page 4,
or the reported geometry info is invalid.
WARNING: Disk geometry is based on capacity data.
The current rpm value 0 is invalid, adjusting it to 3600
done
c4t1d0: configured with capacity of 232.87GB
AVAILABLE DISK SELECTIONS:
0. c4t0d0
/pci@0,0/pci1043,8277@1f,2/disk@0,0
1. c4t1d0
/pci@0,0/pci1043,8277@1f,2/disk@1,0
Specify disk (enter its number): 0
selecting c4t0d0
[disk formatted]
# format>fdisk

and create second (third) partition with type "Other OS ".

Total disk size is 30401 cylinders
Cylinder size is 16065 (512 byte) blocks
Cylinders
Partition Status Type Start End Length %
========= ====== ============ ===== === ====== ===
1 Active Solaris2 1 9136 9136 30
2 [-----] Other OS 9137 12136 3000 10
3 [-----] Linux native 12137 12149 13 0
4 [-----] EXT-DOS 12150 30400 18251 60



Creating zpool :-


# zpool create xvmpool c4t0d0p2 (3)
# zfs create -V 25G xvmpool/snv-disk

Log out root and run:-

$ pfexec virt-manager

Set installation partition to /dev/zvol/dsk/xvmpool/snv-disk
Attempt to use image file like /export/home/images/root.img , located on ZFS will make virt-manager
(virt-install) performance unacceptable, at least through my experience.











CentOS 5.2 PV guest snapshots:-








SNV_103 HVM been built with /dev/zvol/dsk/rpool/disk1 (zfs create -V 12G rpool/disk1)








References.
1.Getting xVM to work in Opensolaris 2008.05